[問題] 求救Spritecraft打不開(已解決)

看板 Minecraft
作者
時間
留言 6則留言,2人參與討論
推噓 3  ( 3推 0噓 3→ )
最近看許多身邊的朋友都嘗試在minecraft做地圖繪 想說我也來試看看 結果上網爬文下載了Spritecraft卻打不開 下載下來解安裝後 https://i.imgur.com/dC0mO54 執行RunSpritecraft.bat https://i.imgur.com/yLvAp7u CMD在出現這串文字後就直接消失了 有上網找過別人遇到的類似問題 大多數人都是java版本過舊(執行程式最低要求java7) 可是我自身的版本是java8應該沒問題阿... 在重載java後依然打不開 我的java版本 https://i.imgur.com/fTmZSEc 想問版上大佬這題怎解? 這是小弟生涯首次在ptt上發文,如果有不適當處請見諒 --
※ 發信站: 批踢踢實業坊(ptt.cc), 來自: 1.173.191.198 (臺灣) ※ 文章網址: https://www.ptt.cc/bbs/Minecraft/M.1627928622.A.EB2.html
1Ftwosheep0603: 有沒有可能是你的Spritecraft版本過舊? 08/03 03:50
我是載目前官方最新的1.1.7版
2FLPH66: 你的 java 8 的小版本多少? (java -version 可以看) 08/03 05:05
我有貼在上面了可是我不確定要怎麼看,應該是 1.8.0_301-b09
3FLPH66: OK, 看起來找到問題了: 你是用 Java 16 執行的 08/03 16:07
4FLPH66: (命令列的 java -version 回報的是 Java 16) 08/03 16:07
5FLPH66: Java 16 有一些新的安全性限制, 舊程式碼可能無法執行 08/03 16:09
6FLPH66: 如果你能用 Java 8 執行應該就沒問題了 08/03 16:09
感謝大大~我把版本切換成 java 8 後果然成功了!!! 只是要幫朋友開 Minecraft 1.17伺服器時還是要手動切回 java 16 有點麻煩 ※ 編輯: eddie7k7k (1.173.191.198 臺灣), 08/03/2021 18:23:29